Projekt: Abakus VCL
Bug report

State: All

User infoRobert Craig
11.Feb.19 1:52
Betreff:
TAbClock and TAbAnalogClock Error

Beschreibung:
In a Delphi 10.2 .exe using either or both clock components, the AB clock displays will agree with each other but lag system time by a significant fraction a full second.

Schritte zum Reproduzieren:
1. Run a SNTP client such as NixieClock (http://www.clockvault.com/clocks/nixiehowto.htm ) to properly set system time.

2. Run any application using TAbClock and/or TAbAnalogClock.

3. Compare the seconds of the time displayed to either the Windows system time clock or a radio tuned to NIST radio WWV time signals.

Files:
clockerror.jpg (325 kB)

User infoRobert Craig
11.Feb.19 1:53
Kommentar:
Screen shot displaying error

User infoRobert Craig
11.Feb.19 21:00
Kommentar:
The bug seems to be in the initialization of the clock when the program starts. If you close then relaunch the EXE multiple times the difference between the component's displayed time and system time will vary, sometimes appearing to be right on.

User infoadmin
13.Feb.19 17:29
Kommentar:
Problem fixed, new version online within few hours.


Sie sind nicht Angemeldet
Sie können keine Beiträge in dieses Forum schreiben.
Sie können auf Beiträge in diesem Forum nicht antworten.
Sie können Ihre Beiträge in diesem Forum nicht bearbeiten.
Sie können Ihre Beiträge in diesem Forum nicht löschen.
Sie können an Umfragen in diesem Forum nicht mitmachen.
Sie können keine Dateien in diesem Forum posten.